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What is in this Manual

We hope that you will find this manual informative and useful. Our objective is to
complement what you will learn from using the program and its on-line help. Whenever
possible, we try to anticipate your questions and any problems you might face.

Here’s what you will find in this manual:

Chapter 1: Introducing Clip’nSave

Chapter 1 will familiarize you with some terminology and new ideas that will appear in
the other chapters. We will also explain the role that Clip’nSave plays in Windows and
what you can expect to see when you first run Clip’nSave.

By the time you finish Chapter 1, you should have a good idea of what Clip’nSave is and
how it can help you.

Chapter 2: Installing Clip’nSave

Chapter 2 explains how to install Clip’nSave on your hard disk and set up Windows correctly.

Even if you’re in a rush, or if you’re an experienced Windows user, we still recommend
that you at least skim through Chapter 2.

Chapter 3: A Quick Tour of Clip’nSave

Chapter 3 gives you a quick hands-on tour of most Clip’nSave functions. Use it to
familiarize yourself with the basic Clip’nSave operations.

You can use Chapter 4 to learn more about what you can do with Clip’nSave.

Chapter
Introducing
Clip’nSave 1
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Chapter 4: Using Clip’nSave

Chapter 4 describes all Clip’nSave commands. It shows how to set capture options,
capture different parts of the screen, work with different graphics files, and perform
more advanced operations.

Given that Clip’nSave is a Windows program, you should have no trouble navigating
through the menus and using the built-in help. Nevertheless, Chapter 4 is there when you
need it.

Chapter 5: Tips’nTricks

Chapter 5 is a collection of tips and tricks that we and others have found useful while
working with Clip’nSave. It is the result of many months of testing, both by the program-
mers who wrote Clip’nSave and by the thousands of users who have been working with
this and the OS/2 version of the program.

Appendix A:  File Formats

Appendix A gives detailed information on the clipboard memory and graphics file
formats supported and used by Clip’nSave.
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About the Clipboard

Before you use Clip’nSave, it’s important that you understand how the Windows Clip-
board is used.

Almost all Windows programs have an item on their menu bar entitled Edit (see figure 1-1
below). In turn, the Edit menu typically contains “Copy” and “Paste” functions.

Figure 1-1. Notepad clipboard functions.

The idea is that you identify and copy an object or collection of objects to the Clipboard,
which is an area of off-screen memory where the objects are placed. Examples of objects
are pictures or lines of text.

When you paste the object, Windows copies it back from Clipboard memory into your
application.

What makes the Clipboard so useful is that the memory is shared. You can copy an object to
the Clipboard from one program and then paste it back into an entirely different program.

Because of the Clipboard, there is absolutely no requirement for programs to be aware of
one another. It is completely up to you, your mouse, and the Edit menu to decide when
and how much information to transfer between programs via the Clipboard.
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About Bitmaps

For all of this Clipboard stuff to work, objects copied to the Clipboard must be in some
sort of mutually understandable format that all programs can interpret.

One popular Windows Clipboard format is the bitmap. Simply defined, a bitmap is a
collection of bits representing colored dots that make up a picture, and a format for
storing this information in Windows memory.

Bitmaps include information about the picture, such as dimensions, number of bits per
pixel (or dot), and the palette of colors used. Some bitmaps need only two colors, black
and white; others may use as many as sixteen or 256 different colors in their respective
palettes; still others may represent a selection of over sixteen million different colors.

When a program copies an object to Clipboard memory, it first converts the object to
bitmap format. When a second program pastes the object from Clipboard memory, the
object is converted from bitmap format.

Bitmaps are used throughout Windows. The mouse pointer is a bitmap; icons are bitmaps;
fonts are bitmaps; windows are bitmaps and, as you will discover later, the entire screen
is one big bitmap.

Device Independent Bitmaps (DIB)

Clip’nSave also works with Windows’ newest bitmap format, the Device Independent
Bitmap, or DIB for short.

A DIB is a structure in Windows memory that describes the actual appearance of an image,
regardless of where the image came from or where it’s going. Device-independent bitmaps
contain, besides their pixel data, information about the color, size and resolution of the
original picture. When devices or programs receive a DIB, they are free to use as much or
as little information as they like. Output devices such as displays and printers generally use
all the data they are physically able to reproduce. For example, color information becomes
shades of gray or disappears altogether when DIBs are sent to a monochrome printer.
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About Clip’nSave

Clip’nSave is a deceptively powerful and useful program. You can:

• Capture anything you can see on your screen;

• Save the images you captured using a variety of popular graphics file formats;

• Import images from disk in popular graphics formats for use in Windows;

• Use Clip’nSave as a graphics conversion program, importing files in one format
and exporting them in another;

• Print any bitmap on the Clipboard, including screen image bitmaps created by
Clip’nSave itself, on any printer supported by Windows.

The following describes these features in more detail:

A Screen Capture Program

As a screen capture program, Clip’nSave creates bitmaps (or DIBs, or both) from screen
images and places these bitmaps on the system Clipboard. Anything you see on your
screen can be captured and copied to the Clipboard with a single keystroke.

As with bitmaps placed on the Clipboard by any other application, these screen image
bitmaps may be viewed, edited, recaptured, saved, pasted, and printed.

Clip’nSave offers six alternatives for capturing screen images. You can capture:

• The active window1 ;

• The desktop, or entire screen;

• Any window and its control and child windows;

• Any window’s client2  area; or

• Any rectangular portion of the screen; or

• Freehand mode where you select an area of any shape.

1 The active window is officially defined as the “window with which you are interacting”.
We like to think of it as the window whose title color is different from all the others.

2 The client area is that part of an application window which is implemented by the
application.
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Clip’nSave implements system-wide hotkeys so the active window or desktop can be
captured any time — even from within another program. While other programs can only
do this with a timed capture, Clip’nSave lets you decide. You can capture an image right
away, or a few seconds later.

You can even capture the mouse pointer.

There are many options available to customize your screen snapshots, including the
ability to customize the system-wide hotkeys.

Importing Graphics with Clip’nSave

Clip’nSave can also import image files from disk, directly onto the Windows Clipboard.

The ability to load files in one format, combined with the ability to save in another,
makes Clip’nSave a convenient graphic conversion program.

Because it displays image files on the Clipboard, Clip’nSave is also a great tool for
previewing graphics, or browsing your image collection, before pasting a graphic into
other applications.
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A Bitmap Conversion Program

You can now save to disk any Clipboard bitmap, including screen image bitmaps created
by Clip’nSave itself.

Clip’nSave can convert a Clipboard bitmap to any of the following image file formats:

• Bilevel, grayscale3 , 16- or 256-color, and 24-bit color Windows Bitmap (.BMP);

• Bilevel, grayscale, 16- or 256-color OS/2 Presentation Manager Bitmap (.BMP);

• Bilevel, grayscale, 16- or 256-color, and 24-bit color Aldus TIFF (.TIF) with 3
possible compression methods: no compression, PackBits, or Lempel-Ziv-Welch;

• Bilevel, grayscale, 16- or 256-color, and 24-bit color ZSoft PC Paintbrush (.PCX);

• Bilevel, grayscale, 16- or 256-color Adobe PostScript or Encapsulated PostScript
(.PS/.EPS); and

• Bilevel, grayscale, and 16- or 256-color CompuServe Graphics Interchange Format
(.GIF) with optional interlacing.

The wide variety of image file formats and bitmap conversions provided by Clip’nSave
make the program an ideal complement to virtually any application that imports graphics
under Windows, DOS, OS/2, Macintosh, and other platforms.

A Bitmap Printing Program

Clip’nSave can print any bitmap on the Clipboard, including screen image bitmaps created
by Clip’nSave itself, on any printer supported by Windows. Local and networked printers
work equally well.

Clip’nSave automatically ensures that the printed bitmap maintains its size and aspect
ratio4 , and that the image is centered both horizontally and vertically on the printed
page.

3 To save a color bitmap as grayscale, Clip’nSave replaces the colors with different
intensities of “grays”, ranging from white to black — just like a black-and-white
television handles color broadcasts.

4 Aspect ratio is the ratio of horizontal to vertical size.  When aspect ratio is maintained,
circles will print like circles (and not like eggs).



1-8   Introducing Clip’nSave

Figure 1-2. Clip’nSave window appearance.

If you look toward the bottom of the figure, you will notice that there are three new
controls not normally included in standard windows:

• The Status Window, located just below the horizontal scroll bar at the bottom left of
figure 1-2, provides an automatic one-line description of the currently highlighted
menu command.

The status window complements the more extensive context-sensitive Help subsys-
tem accessed via the F1 key.

Anatomy of a Clip’nSave Window

Figure 1-2 is a screen image of a typical Clip’nSave window.

Status Window Bitmap Description Window
Home-up Button
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• The Bitmap Description Window, immediately to the right of the status window,
provides the dimensions and number of colors in the currently displayed clipboard
bitmap.

• Pressing the Home-up Button, located between the two scroll bars just above the
bitmap description window, will send both the horizontal and vertical scrollbar
buttons back to their respective origins.

The home-up button is a convenient way of “homing” the image and makes good
use of the otherwise vacant space between the two scroll bars.
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Overview

Clip’nSave consists of the following files:

• CLIP.EXE is the main executable program file;

• CLIPLIB.DLL is a small dynamic link library used to implement system-wide
hotkeys;

• CLIP.HLP is the on-line help manual;

• INSTALL.EXE is the Windows’ installation program for Clip’nSave; and

• INSTALL.INF is a script file for the installation program.

You might also find a README.TXT file that contains last-minute instructions, revi-
sions or updates that occurred since the last printing of the Clip’nSave User Guide. This
is a text file that can be read with Windows Notepad.

Program installation consists of copying these files to your hard disk and adding an icon
to one of your Program Manager groups.

We recommend that you create a new directory and copy all files to this new directory.
Keeping the files together will make installation and future updates much simpler.

NOTE If your distribution diskette is defective, repeat the installation procedure
from the other diskette enclosed in the package. Clip’nSave includes both 5¼”
and 3½” diskette formats.

Chapter
Overview 2
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Program Installation

You can install Clip’nSave automatically with the supplied installation program, or
install it manually. The sections below describe how to do either. Just to be on the safe
side, make sure you write-protect the Clip’nSave distribution diskette before starting, or
make a backup copy of the diskette and install from the backup.

Installing Files with the Install Program

This example describes how to install Clip’nSave in the \CLIP directory on a hard disk
called C:. You’re free to choose a different directory name and hard disk. Just remember
to substitute your selection where you see C:\CLIP in step 1 below.

To run the Install program:

1 Insert the Clip’nSave distribution diskette in your floppy disk drive (for example A: ).
Then use File Manager or Program Manager to run INSTALL.EXE from the diskette.

The Install program will load and your screen should resemble the illustration below.

Figure 2-1. Installation Program.

2 Follow the instructions on the installation program screens.

The Install program creates a Program Item called “Clip’nSave” (with its current version
number), and places it in a Program Group called “Dynalink”.

You can start Clip’nSave by double-clicking on the camera icon. Go on to Chapter 3 to
learn how to use Clip’nSave.

If you prefer, you can also install Clip’nSave manually as described in the next section.
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Installing Files Manually

This example describes how to use DOS to install Clip’nSave manually in the \CLIP
directory on a hard disk called C:. You’re free to choose a different directory name and
hard disk. Just remember to substitute your selection wherever you see C:\CLIP in steps
1 and 2, and to install all files in the same directory.

To install Clip’nSave manually:

1 From the DOS prompt, create a new directory:

mkdir c:\clip

2 Insert the Clip’nSave distribution diskette in your floppy disk drive. Copy all the
files from the product diskette to the new directory:

copy  a:\*.*  c:\clip

3 Run the Windows Program Manager and add a new entry to one of your program
groups. The command line for the new entry should read C:\CLIP\CLIP.EXE.

4 Start Clip’nSave by double-clicking on the camera icon.

NOTE If you can’t run Clip’nSave, the most common problem is Windows failing
to find CLIPLIB.DLL. To resolve this problem, either add C:\CLIP to your path, or
move CLIPLIB.DLL to your Windows directory, or make C:\CLIP your working
directory before trying to run the program.
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A Quick Tour of Clip’nSave

In this chapter, you will learn how to start and use Clip’nSave to capture, edit,  print and
save images from your screen.

You will also learn how to:

• Open and view graphics files created by Windows, Clip’nSave, and other programs;

• Save bitmaps to different graphics file formats;

• Translate graphics files between different file formats;

• Paste graphics into other Windows applications; and

• Print from Clip’nSave.

You should already be familiar with the standard Windows user interface. The chapter
assumes that you know how to start and stop programs, move and size windows, get in
and out of menus, and fill in dialog boxes.

NOTE This chapter assumes that this is the first time you are running Clip’nSave.
If you already changed some Clip’nSave menu settings, you can reset the program
to its default settings by deleting the file CLIP.INI from your Windows directory.
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Capturing the Entire Screen

This section presents an example of how to use Clip’nSave to capture the entire screen.
It also describes how to look at different views of the captured image,  paste the image
into another application, and save the image to a disk file.

To capture the entire screen:

1 If you haven’t already done so, start Clip’nSave by double-clicking on the Clip’nSave
camera icon in the Program Manager. The Clip’nSave window will appear on your
display.

2 To capture the entire screen, press F12. If you don’t have an F12 key,  select
“Desktop” from the Capture menu.

The Clip’nSave window will disappear for a second, the capture will take place, and  the
Clip’nSave window will reappear with the captured image inside it.

Viewing Options

Here are a few things you might notice about the image that you captured:

• The status line at the bottom of the Clip’nSave window shows you the size of the
captured image in pixels and the number of bits used to define each pixel.

• Since the captured image is so large (the size of your screen), the Clip’nSave
window shows you only part of it.

Below are a few Clip’nSave features you can use to
see more of the image you’ve captured. None of these
features affect the captured image itself, only the way
it is displayed.

Scroll the image

If the image is larger than the Clip’nSave window, you
can use Clip’nSave’s scroll bars to view any part of
the captured image that is currently outside the
window boundaries.
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Size the window

You can also make the Clip’nSave window larger
by holding the mouse pointer on any corner of the
window, and stretching the window in any direction.

Stretch to fit

Instead of stretching the window to fit the image, you can also do the opposite:  scale the
image to fit whatever size window is currently being displayed. Click on Clip’nSave’s
View menu. You will notice that a check mark appears beside “Actual Size”. This inditates
that the image is being displayed at full size.

If you click the mouse on “Stretch to Fit”,
whatever the size of the Clip’nSave window,
the image will be scaled to fit that window. As
you stretch or compress the Clip’nSave win-
dow, the image will stretch or compress with it.

To get the biggest view possible, select “Actual
Size” from Clip’nSave’s View menu, and then
use the features described next:
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Maximized view

Maximize the Clip’nSave window by clicking on the
Maximize button at the top right of the window, or
selecting “Maximize ” from the Control menu. (The
Control Menu is defined by Windows. It’s the one
marked by a horizontal bar in the top left hand corner
of the Clip’nSave window).

The window will fill the screen. This  option will show
you almost all of the captured bitmap, but since the
bitmap is of the whole screen,  the image is still cropped
by Clip’nSave’s scroll bars.

Hiding Clip’nSave controls

If you want to see the entire desktop as captured by Clip’nSave,  make sure that the
Clip’nSave window is still maximized, and press CTRL-H.

Instead of CTRL-H, you can also click on Clip’nSave’s View menu and select “Hide
Controls”.

In either case, the scroll bars will disappear, and the image of the desktop will fill your
display.

This is a bit tricky, since it’s impossible to tell whether the image is the actual desktop or
a Clip’nSave graphic. They are the same graphic. Anything on the Window’s screen is a
bitmap.

You can resolve this easily enough:  To redisplay the Clip’nSave window controls, press
CTRL-H again, or double-click on any part of the screen.
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Pasting a Captured Image into Paintbrush

When a captured bitmap appears in Clip’nSave’s window, it is also automatically placed
on the Windows Clipboard. This means that you can immediately paste the image into
any other Windows program that accepts bit-mapped graphics.

To paste a full-screen image into Paintbrush:

1. Start Paintbrush and select “Zoom Out” from its View menu.

2. Select “Paste” from its Edit  Menu.

The bitmap you captured will be pasted from the Windows clipboard into Paintbrush,
and you can now use Paintbrush to edit the image.

This operation illustrates an important point about Clip’nSave. Anything in the Clip’nSave
window is also on the Windows Clipboard.

Figure 3-1. Bitmap pasted into Windows Paintbrush.
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Saving the Captured Image

After you have captured an image, you can save it to disk in several graphics file
formats. Press CTRL-S, or click on Clip’nSave’s File menu, and select “Save As....”  In
either case, the following dialog box will appear on your display:

Figure 3-2. “Save as” dialog box.

The dialog box allows you to choose a file name and a graphics file format in which to
save the file. It also gives you options for how many colors will be used to save the file,
whether you want the colors converted to gray scale, and whether you want the file saved
in a compressed format if possible.

The “File Name” box shows you the default extension for the bitmap you have captured
(.BMP), also any files in the current directory that match that extension. The “Directories:”
column shows the current directory name, and allows you to select the drive and/or
directory where the image will be saved.

With the “Save File as Type” box, you can select the format of files created by Clip’nSave. This
allows you to export captured graphics to any program that can read one of the supported
formats. To see all the available formats, click on the arrow at the right side of the box.

To save the image as a Windows bitmap:

1. Type DESKTOP in the “File Name:” field.

2. Verify that the file name is DESKTOP.BMP, and then click the “OK” button.

This will create a file that can be read by the Windows Paintbrush program.
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Loading Files from Disk

Using the “Open” function on Clip’nSave’s File menu, you can load graphics files
created by other programs into Clip’nSave. This is true for any program that can save
files in a format Clip’nSave can recognize.

Select “Open” from the Clip’nSave File Menu. The following dialog box will appear on
your display:

Figure 3-3. “Open” dialog box.

Since the default file type is a .BMP file, the dialog box currently shows you all files
with the .BMP extension in the current directory. You could search for other types of
files by picking one of the file formats listed in the right-hand column of the dialog box.
For now, select your DESKTOP.BMP file.

You can preview the file before you load it into Clip’nSave by pressing the “Preview”
button. A window containing the image will appear on your screen.

You can display the preview in two ways:

• If you click the “Fit in Window” box, an ‘x’ will appear in the box and the graphic
will be shrunk to fit in the Preview window.

• If you click the box again, the Preview window will display any portion of the full-
size graphic that will fit in the window.
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When bitmaps are displayed with “Fit in Window” checked, the original aspect ratio
(ratio of vertical to horizontal size)  is maintained. Images are aligned with the top or left
margin if they don’t fill the box. (For more information on getting the best display with
this feature, refer to Previewing Bitmaps in the File Menu section of Chapter 4.)

You can use “Preview” to display any graphic that Clip’nSave can read. Simply select
the file type and file name. While the Preview window is open, any file you select will be
displayed in the window.

When you are ready to load the selected image, press the “OK” button and the image
will appear in Clip’nSave’s window (and on the Windows clipboard).

Once the image is in Clip’nSave, you have several options:

• You can paste it into another Windows application;

• You can print it;

• You can save it to disk, either in its current format, or in any file format supported
by Clip’nSave.

NOTE The “Load as...” button on the Open  dialog box lets you choose whether
files are placed on the clipboard as bitmaps, “device-independent” bitmaps (DIB),
or both. Bitmaps are better if you intend to paste the image into another program;
DIBs are better for file conversion from one graphics format to another.
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Printing

If you have a graphics printer, you can print any image captured by Clip’nSave, or any
graphic Clip’nSave can read.

Make sure the graphic is in the Clip’nSave window, and press CTRL-P (or select “Print”
from the File menu). The image will be directed to the printer you chose in Windows
setup.

Note that the image you get depends on what kind of printer you have. Each printer has
its own way of translating gray shades, colors, etc. For more information on getting the
best results on your printer, refer to Chapter 4.

Saving in Another Format

To save the currently displayed image in another format, simply choose “Save As...”
from Clip’nSave’s File menu. Click the mouse pointer on the arrow beside the “Save
File as Type” box and select the type of file you want to create. The current filename will
remain in the “File Name” box, followed by the correct extension for the new format.
When you press “OK”, the file will be created.

In Conclusion...

This concludes the tutorial section of this Guide. By now you should have a good
understanding of many of  Clip’nSave’s functions.

But the tutorial is just an introduction. The next chapter gives you the whole story:

• Explains all Clip’nSave commands.

• Tells you more about capture options.

• Shows how to capture various parts of the screen.

• Explains how to work with different file formats.

• Tells you what to expect when you paste into other Windows programs.

• Discusses some of the issues that arise when using certain  printers.
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Chapter
Using

Clip’nSave 4
What You’ll Learn in This Chapter

This chapter provides detailed information about Clip’nSave functions. You should
already be familiar with the standard Windows user interface. This chapter assumes that
you know how to start and stop programs, move and size windows, get in and out of
menus, and fill in dialog boxes.

Overview of the Menus

Clip’nSave has the following menus:

• The File menu is used to open files, to save files or to print bitmaps;

• The View menu is used to stretch or delete a bitmap, or to temporarily hide the
window controls, or to select the displayed bitmap format;

• The Options menu is used to set various screen capture options or change the
system colors;

• The Capture menu is used to capture all or part of the screen and place the
resulting bitmap on the clipboard.
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File Menu

Figure 4-1. “File” menu.

Menu Item Shortcut Description

Open... CTRL- O Loads a bitmap from a disk file onto the
clipboard in either DIB (device-independent
bitmap) or bitmap format. The file may be
in any supported format.

Save As... CTRL- S Saves any clipboard bitmap to a named disk
file in any of a variety of formats.

Print CTRL- P Prints any clipboard bitmap on the currently
selected printer.

Printer Setup... Selects a printer and displays and/or
modifies its setup options.

Exit Exits Clip’nSave.

See also the sections entitled Saving Bitmaps to Disk and Printing Bitmaps.
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View Menu

Figure 4-2. “View” menu.

Menu Item Shortcut Description

Stretch to Fit CTRL- + (plus) The bitmap is displayed so that it fits in the
Clip’nSave window. The bitmap is unaffected.

Actual Size CTRL- – (minus) Turns off Stretch to Fit. The bitmap is
displayed at its actual size.

Clear DEL Removes a bitmap from the clipboard and
clears the Clip’nSave window.

Hide Window Controls CTRL-H Hides the Clip’nSave menu, title bars,
Control menu, scroll bars, and all of the other
Clip’nSave window controls. To redisplay the
controls, press Ctrl-H or double-click on any
part of the Clip’nSave window.

DIB Bitmap This item appears in solid type when the
clipboard contains a “device-independent”
bitmap (DIB). When both a bitmap and a
DIB are on the clipboard, if you select this
item, a checkmark will appear beside it and
the DIB will be displayed.

Bitmap This item appears in solid type when the
clipboard contains a bitmap. When both a
bitmap and a DIB are on the clipboard, if
you select this item, a checkmark will
appear beside it and the bitmap will be
displayed.

See also the section entitled Viewing Options.
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Options Menu

Figure 4-3. “Options” menu.

Menu Item Shortcut Description

Capture Options ALT-O  C With this dialog box you select whether
Clip’nSave hides during captures, whether
boxes are drawn around captured bitmaps,
whether the size is displayed during rectan-
gle captures, the format in which captured
bitmaps are placed on the clipboard, and
which keys are used as hotkeys. For hotkey
captures, you may choose whether bitmaps
are printed immediately upon capture,
whether the mouse pointer is captured and
how many seconds the capture is delayed.

System Colors ALT-O  S Temporarily substitutes new system colors
so that captured images will use colors that
reproduce well on your printer.

See also the sections entitled Screen Capture Options and Screen Capture Functions.



Using Clip’nSave   4-5

Capture Menu

Figure 4-4. “Capture” menu.

Menu Item Shortcut Description

Window CTRL-W Captures the window that you click with
your mouse.

Client CTRL-C Captures the client area of the window that
you click with your mouse.

Rectangle CTRL-R Captures any rectangular portion of the
display that you select with “rubber band”
lines.

Freehand CTRL-F Captures any portion of the screen, regular
or irregular. You define the boundaries with
the mouse.

Active Window Default is F11 Immediately captures the active window
(system-wide hotkey).

DeskTop Default is F12 Immediately captures the entire desktop
(system-wide hotkey).

See also the sections entitled Screen Capture Functions and Screen Capture Options.
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Getting Help

Clip’nSave provides three kinds of help. When you select any Clip’nSave menu item, a
one-line description of its function appears in the bottom left of the Clip’nSave window.
In addition, most dialog boxes have a “Help” button. Finally, context sensitive help is
always available when you press F1.

Figure 4-5. “Help” menu.

The Help menu provides access to the following sections of the on-line manual:

Menu Item Shortcut Description

Contents ALT-H  C Displays the Clip’nSave help table of
contents.

Keyboard ALT-H  K Displays help for Clip’nSave keyboard
keys.

Menu Commands ALT-H  M Displays help for Clip’nSave menus.

Using Help ALT-H  H Describes how to use Windows help.

About Clip’nSave... ALT-H  A Displays a dialog box showing the Clip’nSave
version number and copyright information,
also information about the amount of available
memory.
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The Basics

The following describes how to start Clip’nSave, the various ways commands may be
invoked, how to use the Control menu, and how to exit Clip’nSave when done.

Starting Clip’nSave

You start Clip’nSave like any other Windows program. Double-click on Clip’nSave’s
camera icon:

The Clip’nSave window will appear on your display:

Figure 4-6. Startup display.

Exiting Clip’nSave

You can exit Clip’nSave by selecting “Exit” from the File menu, or pressing CTRL-X.

You can also exit Clip’nSave from its Control menu by selecting “Close” or pressing Alt-F4.
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Invoking Commands

Clip’nSave commands are invoked using either the mouse or the keyboard. Clip’nSave
also has hotkeys that can capture the active window or the desktop even if Clip’nSave is
not the active application.

Mouse activated

Whenever Clip’nSave is the active application, you can invoke Clip’nSave commands by
using the mouse to select a Clip’nSave menu, an item on that menu, and any part of a
dialog box displayed by that item. Some Clip’nSave capture commands (Window,
Client, Rectangle, Freehand) require that you use the mouse to define the area to be
captured. See Screen Capture Functions for details.

Keyboard activated

There are several ways to invoke Clip’nSave commands using the keyboard:

1 Display a menu by holding the Alt key and pressing the underlined letter of the
menu’s name.

2 You select a menu item by pressing the underlined letter in its name.

3 When completing a dialog box, you can select an item by pressing ALT and the
underlined letter in its name, or by using the Tab key to switch from field to field.

4 Some menu items contain keyboard shortcuts. Shortcuts invoke functions without
displaying menus. For example, the Capture menu lists the “Window” command as
follows:

Even if the menu is not visible, CTRL-W will invoke the “Capture Window” command.

System-wide hotkeys

Clip’nSave lets you choose two system-wide hotkeys. These keys let you capture the
active window or desktop anytime, even if Clip’nSave is not the active application. The
default hotkey for a window capture is F11, and for a desktop capture is F12.

If the default hotkey selections conflict with other programs, you can change them using
the “Capture Options” item on the Options menu.
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Using the Control Menu

Clip’nSave’s Control Menu appears in two places:

1 Press the horizontal bar in the top left corner of Clip’nSave’s window. If you select
the “Minimize” option, the Clip’nSave window will shrink to its icon (the camera).

2 When a program runs as an icon, the Control menu appears when you click once
on the icon (see Figure 4-7).

Figure 4-7. Clip’nSave’s “Control” menu’s “Capture” menu.

In addition to the commands found on most programs’ Control menus, Clip’nSave’s
Control menu features a “Capture” item. This cascading menu contains Clip’nSave’s
capture commands.

If you use another program primarily and only want to use Clip’nSave’s capture func-
tions, we suggest that you set the “Capture Options” appropriately, and use the Control
menu’s Minimize option to shrink Clip’nSave to an icon. Click the icon anytime you
need a Clip’nSave capture function. If you need other Clip’nSave functions, use the
Control menu’s “Restore” function.

Be careful not to double-click the Clip’nSave icon since this is equivalent to the Control
menu’s “Restore” command and will restore Clip’nSave’s window.

Since Clip’nSave can capture while running as an icon, it needs very little space on the
screen. This, and the fact that captured bitmaps are always placed on the Windows
clipboard, make it the ideal complement to graphics programs that don’t have a screen
capture facility.



4-10   Using Clip’nSave

Screen Capture Functions

The Capture menu presents Clip’nSave’s capture options. Each captures in a different
way and is invoked using either the mouse or the keyboard.

The Capture menu is also available on Clip’nSave’s Control Menu. For more informa-
tion on using the Control menu, refer to the section entitled Using the Control Menu.

The menu presents the following options:

Window Capture

A window consists of a client area and several controls such as a title bar, a menu, a
sizing border, and scroll bars. The Window capture grabs the window you select includ-
ing all its controls.

Figure 4-8. Sample “Window” capture.

To invoke a Window capture:

• Type CTRL-W; or

• Select “Window” from the Capture menu (see page 4-5); or

• Select “Window” from the cascading Capture menu on Clip’nSave’s Control menu.

The mouse pointer will change to a hand with an extended finger.
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To identify and capture the window:

• As you move the mouse pointer, the area to be captured will be indicated by a
“sizzling” border. Click the left mouse button to capture the part of the screen that
the border encloses.

To cancel a Window capture:

• Click the right mouse button.

Client Capture

The Client area is that part of an application window that is implemented by the
application. For example, the icons are displayed in Program Manager’s client area.

Figure 4-9. Sample “Client” capture.

To invoke a Client capture:

• Type CTRL-C; or

• Select “Client” from the Capture menu (see page 4-5); or

• Select “Client” from the cascading Capture menu on Clip’nSave’s Control menu.

The mouse pointer will change to a hand with an extended finger.
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To identify and capture the client area:

• As you move the mouse pointer, the area to be captured will be indicated by a
“sizzling” border. Click the left mouse button to capture the part of the screen that
the border encloses.

To cancel a Client capture:

• Click the right mouse button.

Rectangle Capture

A Rectangle capture is used to “cut out” any rectangular section of the display screen.

Figure 4-10. Sample “Rectangle” capture.

To invoke a Rectangle capture:

• Type CTRL-R; or

• Select “Rectangle” from the Capture menu (see page 4-5); or

• Select “Rectangle” from the cascading Capture menu on Clip’nSave’s Control
menu (see figure 4-7).

The mouse pointer will change to a pair of crosshairs.
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To identify the rectangle:

1 Move the intersection point of the crosshairs to one corner of the rectangle and hold
down the left mouse button to mark this point. Do not release the mouse button.

A second pair of crosshairs will appear.

2 Move the intersection point of the second pair of crosshairs to the diagonal corner
of the rectangle and release the left mouse button.

To cancel a Rectangle capture:

• Click the right mouse button.

Freehand Capture

A Freehand capture is used to “cut out” any section of the display screen you define with
the mouse. The area’s outline can be irregular (i.e., polygonal) with up to 1,000 edges. In
figure 4-11, the left window shows how an area is selected. On the right is the result of
the capture.

Figure 4-11. Sample “Freehand” capture.
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To invoke a Freehand capture:

• Type CTRL-F; or

• Select “Freehand” from the Capture menu (see page 4-5); or

• Select “Freehand” from the cascading Capture menu on Clip’nSave’s Control
menu (see figure 4-7).

The mouse pointer will change to a pair of crosshairs.

To identify the area:

• At the starting point of the area you want to enclose, press the mouse button and
move the crosshairs in any direction to enclose any area. Do not release the mouse
button until you reach the ending point of the area you want to enclose. When you
release the button, the capture will take place.

If you do not enclose the area completely, Clip’nSave will assume that a line was
drawn between the two end points:

To cancel a Freehand capture:

• Click the right mouse button.

Active Window and Desktop Capture

You can invoke the Active Window and Desktop capture functions from any Windows
application, unlike the other capture functions which can only be selected while the
Clip’nSave window is active.

The active window is officially defined as the application window with which you are
currently interacting. We like to define the active window as the window whose title
color is different from all the others.

The desktop is the entire Windows screen display area.

To capture the active window:

• Press F11, or the key you selected with the Capture Options dialog box.

To capture the desktop:

• Press F12, or the key you selected with the Capture Options dialog box.
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If the capture key you defined conflicts with a key used by another application, strange
things can happen. See the section on the Options menu for information on how to
redefine Clip’nSave’s hotkeys.

NOTE If the Capture Options  dialog box has “Hide While Capturing” turned on,
and Clip’nSave is the active window  when you press F11, the desktop will be
captured instead. If you intend to capture a Clip’nSave window or dialog box, turn
off the “Hide While Capturing” option.
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Screen Capture Options

Capture Options...

When you select “Capture Options” from the Options menu, the following dialog box
appears on your display:

Figure 4-12. “Capture Options” dialog box.

Options you set with this dialog box take effect when you click the “OK” button. Their
current settings are saved when you close Clip’nSave, so you do not have to reset them
each time you start the program.

Each option is described below:

Hide Clip’nSave while capturing

If you’re using Clip’nSave to capture full-screen images or to capture screens from
another program, you might not want the Clip’nSave window or icon to appear in the
captured image.

If you click this box to turn on the Hide While Capturing option, Clip’nSave will
conveniently move itself “off-screen” while you capture screen images. When the
capture completes, Clip’nSave will reappear.

If you disable Hide While Capturing, you will be able to capture the Clip’nSave window
as well.
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When you start Clip’nSave for the first time, the Hide While Capturing option is set.

Hint:

• If you do not check the “Hide While Capturing” option, you can capture operations
like window movement and window sizing. If this is the sort of thing you wish to do,
make sure you also set “Delay Capture” to 0 (zero).

Draw box around captured bitmaps

Turn on the “Draw Box Around Captured Bitmaps” option to outline captured images
automatically with a thin black line.

Use this option to add a border to bitmaps created by the Client or Rectangle capture —
 otherwise both would result in images without outlines.

Some graphics import programs can also draw a box around imported images. If you
discover that it’s impossible or too difficult to line up the border “just right” with the
other program, turn on the “Draw Box Around Bitmap” option.

When you start Clip’nSave for the first time, it is set not to draw a box around the
bitmaps it captures.

Figure 4-13. “Client” capture with and without a box.

Show dimensions during rectangle capture

If “Show Dimensions During Rectangle Capture” is on, a small window will appear at
the bottom left of your screen whenever a Rectangle capture is in progress. This window
displays the capture dimensions as you adjust the crosshairs.

This is useful if you require “pixel-accurate sizes” — for example, if you capture screen
images for use as icons.
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When you start Clip’nSave for the first time, “Show Dimensions During Rectangle
Capture” is checked.

Figure 4-14 shows a capture in progress with “Show Rectangle Size” turned on. In this
example, the user is capturing the Clip’nSave icon using a rectangle of dimensions 79
pixels wide by 62 pixels high.

Figure 4-14. Rectangle sizing.

Capture as bitmap, DIB or both

This option selects the format of bitmaps placed on the clipboard. The choices are
bitmap, “device-independent” bitmap (DIB) or both.

A bitmap is a chunk of Windows memory that represents the colored dots that make up a
picture. It also includes information about the picture, such as its size, the number of bits
used for each pixel or dot, and the palette of colors required to  paint the picture. The
format of a bitmap varies according to the device that it was created for. For instance,
bitmaps created for a VGA display are different from bitmaps created for a Hewlett
Packard LaserJet III.

“Device-independent” bitmaps (DIB) are also bitmaps. The only difference is that their
format never changes. As Windows continues to support more devices, supporting all the
different bitmap formats becomes awkward. With DIBs, programs can use one universal
format that describes the appearance of an image in a device-independent manner. DIBs
can be created by or output to any device. Many older programs don’t yet support DIBs.

When you choose “Both” for this option, the Clip’nSave View menu lets you set or
change which type of bitmap is displayed in the Clip’nSave window.

Hints:

• “Capture as Bitmap” is faster than “Capture as DIB”;

• “Load As DIB” (in the Open dialog) is faster than “Load As Bitmap”;

• Many programs can’t paste DIBs from the clipboard, so bitmap is better if you
intend to paste the picture somewhere else.
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Print automatically

When you select this option, hotkey captures send the captured image to both the
Clip’nSave window and the current system printer. For more information on setting up
printers and printing, see Printing Bitmaps.

Include the mouse pointer

Turn on the “ Include Mouse Pointer” option to include the mouse pointer in Active
Window and Desktop screen captures.

The mouse pointer cannot be included in other types of screen captures (i.e. Window,
Client, Rectangle or Freehand) because you need the mouse to identify the capture area.

NOTE that if the mouse is not within the active window rectangle, it will not be
included in Active Window images.

Delay capture

If the Capture Options dialog box specifies a delayed capture, when you press a hotkey,
the speaker on your PC will beep each second until your timer counts down to zero and
the capture takes place.

Redefining hotkeys

The remaining sections of the dialog box redefine the keys used as Clip’nSave’s system-
wide hotkeys. You might need to edit these if you discover a keyboard conflict with
another program, or if the screen capture doesn’t work, or you just don’t like our

choices.

Figure 4-15. Hotkey definition area.

Note that your new definitions will be saved when you exit Clip’nSave and automatically
reinstated the next time you use the program.
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Setting the System Colors

Use the “System Colors” item in the Options menu to temporarily replace the default
system colors. If you forget to restore the colors before ending the program, Clip’nSave
will do so automatically.

System colors are the colors that you would normally change with the Control Panel
program. These are the colors used to paint window borders, backgrounds, system text,
menu and title bars, and so on.

Changing the system colors does not affect icons, bitmaps, or the contents of client
windows drawn by other programs.

You might need to change Windows’s system colors because most printers only print in
black and white: the default system colors do not reproduce well on monochrome printers.
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Editing Bitmaps

Scaling a Bitmap

When you turn on the “Stretch To Fit” option on the Edit menu, the bitmap in the
Clip’nSave window will automatically stretch and/or shrink to fill the client area.

Figure 4-16 below shows how the Stretch To Fit setting affects a bitmap.

Figure 4-16. Using “Stretch To Fit” to scale bitmaps.

When you save, print, or paste a bitmap from the clipboard, the image is saved or printed
at its actual size — whatever the Stretch To Fit setting.

If you wish to resize the bitmap itself and not just the display, do the following: Use
“Capture Options” on the Options menu to turn off “Hide While Capturing”. Then use a
Client or Rectangle capture to recapture the stretched bitmap. To avoid capturing
Clip’nSave’s controls, select “Hide Window Controls” from the View menu (CTRL-H)
before doing your Client capture. The new bitmap will be a scaled version of the original
bitmap.
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Cropping a Bitmap

When you crop a bitmap, you cut away what you don’t want. For example, a Rectangle
capture is simply a desktop capture with everything outside the rectangle of interest cut
away or cropped.

Clip’nSave also makes it possible to crop a bitmap that’s already on the system clipboard.

To crop a displayed bitmap, use “Capture Options” on the Options menu to turn off
“Hide While Capturing”. Then, use a Rectangle or Freehand capture to crop away
everything you don’t want by selecting what you want to keep.

Deleting a Bitmap

This one is easy. To delete a bitmap from the system clipboard — and by definition,
from the Clip’nSave window — press DEL or select “Clear” from the View menu.
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Viewing Options

Once you have captured a bitmap, you can use the View menu to display it several ways. You
can also combine View and Capture menu functions to scale and crop captured bitmaps.

Choose DIB or Bitmap

Clip’nSave places captured images on the clipboard in “device-independent” bitmap
(DIB) or bitmap format. Using “Capture Options” on the Options menu, you can choose
to use either one or both formats.

Similarly, by using the “Load As” button in the Open dialog, you can choose to load
bitmaps from file onto the Windows clipboard in either or both formats.

If  both the bitmap and the DIB versions of the image are on the clipboard, both options
will appear black on the View menu; the checked option is the version currently dis-
played. You can display the other by clicking its option with the mouse. If clipboard
contains only one format, the name of the other will be gray. When no bitmap is dis-
played in the Clip’nSave window, both options are gray.

Hide Window Controls

When dealing with full-screen bitmap images, the various Clip’nSave frame controls (title
bar, menu bar, scroll bars, etc.) will prevent the image from being completely visible, even
when the Clip’nSave window is maximized. If you type CTRL-H or select the “Hide Window
Controls” item from the View menu, then all of the frame controls will conveniently hide
themselves, thereby freeing up some video “real estate” for the bitmap image.

All of the various keyboard controls, including the capture and ;scrolling keys, are still
active when the window controls are hidden. To move the Clip’nSave window, hold
down the mouse button and drag the window to a new location.

To restore the hidden window controls, either double-click the mouse or type CTRL-H.

Stretch to Fit

When you turn on the “Stretch To Fit” option on the View menu, the bitmap in the
Clip’nSave window will automatically stretch and/or shrink to fill the client area. This
doesn’t affect the bitmap on the clipboard, only the display.

If you want to scale the bitmap on the clipboard, recapture the scaled display using a
rectangle or window capture. Remember to turn off the “Hide While Capturing” capture
option beforehand.
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Loading Bitmaps from Disk

Once a file has been loaded onto the clipboard and into Clip’nSave’s window, you can
do any of the following:

• Crop or stretch it using the functions described in Editing Bitmaps.

• Capture all or part of it using functions on the Capture menu.

• Paste it into other programs that accept bitmaps.

• Convert file formats by saving it to disk again in a different format. See Saving
Bitmaps to Disk.

To Load a File from Disk:

Select “Open...” from the File menu, or type CTRL-O. A dialog box will appear in which
you must select the type and then the name of a file to display.

Figure 4-17. “Open” dialog box.

The dialog box lists the files in the current directory whose extensions match the type
selected on the right-hand side of the box. While selecting files, you can change both the
drive and directory to be searched, as well as the file type to search for.

Find the name of the file you wish to load, click on it with the mouse (or type it in the
File Name box), and then click the “OK” button. The file will appear in the Clip’nSave
window, and its name will appear on the title bar.

The “Load As” button opens a dialog box that lets you decide whether the file should be
placed on the clipboard as a bitmap, a “device-independent” bitmap (DIB), or both. For
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more information on bitmap and file formats, see Appendix A. File Formats.

The list of file name extensions corresponding to the available formats is listed on the
right side of the dialog box. The extensions represent the following file types:

BMP Windows Bitmap
DIB Windows or OS/2 Presentation Manager Device Independent Bitmap
RLE Windows Run Length Encoded
PCX ZSoft’s Publisher’s Paintbrush
TIF Tag Image File Format (TIFF)
GIF Compuserve’s Graphics Interchange Format
All Any file (*.*)

For more information on these file types, refer to Appendix A. File Formats.

Previewing Bitmaps

If you want to look at a bitmap before you load it, click on the “Preview” button. The
Preview window will be added to the Open dialog box:

Figure 4-18. “Open” dialog box with “Preview” window.

While the Preview window is open, simply click on the name of any file that Clip’nSave
accepts and the image will appear in the small window.

If the “Fit in Window” box is checked, the bitmap is displayed compressed, otherwise
Clip’nSave displays as much of the image as can fit in the preview window. The compressed
image maintains its aspect ratio and is aligned along the left or top side of the window.

The Preview window disappears when you click the “Preview” button a second time or
double-click a file name. Double-clicking a file will load it onto the clipboard, end the
Open dialog, and display the bitmap.
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Saving Bitmaps to Disk

Any bitmap on the system clipboard, including bitmaps placed there by other applications
or created by a Clip’nSave screen capture, may be saved to disk in any of the supported
file formats. The Save As dialog lets you select the color format of the saved file (Black
& White, grayscale, 16-color, 256-color, or 24-bit color ), and whether files should be
compressed when possible.

To Save a Bitmap to Disk

Select “Save As...” from the File menu, or type CTRL-S to begin the Save As dialog.
Enter a file name and select a file format.

Figure 4-19. “Save As” dialog box.

Enter a file name

The Name entry field is initialized with the file name you last used. Either accept this
name — and the old file will be replaced if the format is the same — or type a new
name.

Clip’nSave will accept any valid DOS file name, including a leading drive letter and
directory path.

Do not type in a file name extension. Clip’nSave will provide an extension based on the
file format you select.
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Select a file format

The intended use of a file generally suggests the best format. Programs importing files
usually have their own ”favorite” formats. Finding the best for your application may take
a little experimentation.

For more information on file formats, refer to Appendix A. File Formats.

Table 4-1 below summarizes the color and compression capabilities of all file formats
supported by Clip’nSave.

Format B&W Grays Color Compress
Windows Bitmap (.BMP) Yes Yes Yes Optional
Device Independent Bitmap (.DIB) same as .BMP
Run Length Encoded (.RLE) same as .BMP
OS/2 Bitmap (.BMP) Yes Yes Yes No
Encapsulated PostScript (EPS) Yes Yes Yes Optional
Graphics Interchange Format (.GIF) Yes Yes Yes1 Always
PC Paintbrush (.PCX) Yes Yes Yes Always
Tag Image File Format (.TIF) Yes Yes Yes Optional2

Table 4-1. Colors and compression available for each file format.

Color conversion

With the Save As dialog box you can also select the color format, grayscale conversion
and whether available compression should be used when creating files.

Clip’nSave creates files with four levels of color: black & white, 16-color, 256-color, or
24-bit color. With the grayscale option, images are saved in 16 or 256 shades of gray.
Lighter and darker shades represent different colors in much the same way as they do in
a black and white photograph.

On the status line, Clip’nSave displays the number of bits per pixel (bpp) used by the
currently displayed bitmap. This is the maximum number of colors a bitmap may use.
They may use less. Bits per pixel relates to the number of colors as follows:

Bits per Pixel Format
1 Black & White
4 16 colors or grays
8 256 colors or grays
24 16,777,216 colors

1 Except 24-bit color.
2 TIFF files have three compression schemes: none, PackBits, or Lempel-Ziv-Welch

(LZW). Can also read CCITT compressed TIFF files.
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Saving as b&w, color or grayscale

Black and white bitmaps can be saved as color files, but this doesn’t magically give them
color. They still appear in black and white, because this is all the information the files
contain.

It’s possible to save color bitmaps as either black and white, grayscale, or color files.

When you save a color bitmap as a grayscale file, Clip’nSave replaces the color palette
in the file with a palette of corresponding levels of “grays”, ranging from white to
black — just like a black and white television converts color broadcasts.

Some devices, like PostScript printers, support grayscale images and reproduce them
well. Some programs — like Microsoft Word, WordPerfect, and Aldus PageMaker —
 import grayscale images and use a technique called dithering when printing them on
devices that don’t support grayscale images directly.

Usually, you should save color bitmaps as grayscale images if your output device doesn’t
support color. If you want to use the saved bitmaps for color slide shows or you have a
color output device, then save in color.

Using compression

Bitmaps, particularly full-screen bitmaps, typically require a great deal of disk space.
Clip’nSave offers sophisticated compression algorithms for several file formats. These
compression techniques shrink files substantially, greatly reducing disk space require-
ments, with no loss of image quality.

Table 4-2 below summarizes the size of each file Clip’nSave creates when saving the same
16-color, full-screen VGA bitmap in grayscale, using every format and compression
scheme. Results vary for every bitmap but this table will give you an idea of how compres-
sion helps.

Format Uncompressed Compressed
Windows Bitmap 153,718 35,604
Encapsulated PostScript 347,634 74,197
OS/2 Bitmap 153,682 cannot be compressed

PC Paintbrush always compressed 65,243
TIFF — PackBits Compression 154,002 29,007
TIFF — LZW Compression 154,002 17,637
GIF always compressed 14,801

Table 4-2. Disk space requirements for a full-screen bitmap.
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File Format Conversion

Using both the File:Open and File:Save As... functions, you can use Clip’nSave as an
image file format convertor: simply load the file to be converted in its current format and
save it in a new one.

In Case of Trouble...

If you can’t read Clip’nSave files with another program:

Many applications don’t support Clip’nSave’s more sophisticated file formats. For
example, we have found very few programs that successfully import 256-color or 24-bit
LZW-compressed TIFF files. Most programs don’t yet support 24-bit color and many
still have trouble with 256-color files. If you’re having trouble reading or importing
color images created with Clip’nSave, try saving the image as black and white, then
work your way up, through grayscale, to color.

If you still can’t read the file, try saving it without compression. If that doesn’t work,
switch to another file format and try again.

If a PostScript file displays differently than it prints:

In an EPS file created by Clip’nSave, there are both PostScript code and a low resolution,
black and white TIFF version of the image. This is necessary since few programs can
display PostScript. The TIFF is used for on-screen viewing, scaling and cropping of the
image.

While the displayed image quality may be poor, this has no effect on how it will print.

After using the TIFF for placement and editing, programs then use the higher quality
PostScript image for final output.

Black & white TIFF previews keep files a manageable size, important since some
programs only accept bitmaps smaller than 64K bytes.

For more information:

Additional information about file formats appears in Appendix A. File Formats. It is also
available by opening the Clip’nSave Help window while you’re in the Save As dialog
box.
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Printing Bitmaps

Any bitmap on the system clipboard, including bitmaps copied there by other applica-
tions or bitmap screen images created with Clip’nSave, may be printed directly from
Clip’nSave.

Clip’nSave uses Windows printer drivers to print images on local or network printers. If
several printers are configured, use Print Setup as described below to select one.

Clip’nSave scales bitmaps, while maintaining their aspect ratio, such that a full screen
bitmap fills the printed page. They are also centered horizontally and vertically.

By enabling the Windows Print Manager, you can continue to work while Clip’nSave is
printing. To enable the Print Manager, start the Windows Control Panel and click on the
“Printers” icon. In the Printers dialog, check the “Use Print Manager” option and press
the “OK” button.

When Print Manager is active, it intercepts all output from Clip’nSave and stores it in a
temporary file on disk. This allows Clip’nSave to complete its print operation much
sooner than if it had to wait for the printer. Once Clip’nSave has finished, Print Manager
takes the disk file and copies it to the printer. As Print Manager runs only when the
computer is not busy with other tasks, you usually don’t notice it working. You can send
several jobs to Print Manager and still use your machine while they print.

For more information on Print Manager, see your Windows User’s Guide.

To Print a Bitmap:

Type CTRL-P or select “Print” from the File menu. A dialog box will appear telling you
that Clip’nSave is printing. If necessary, you can cancel the print job from the dialog
box.

Printing hotkeys

You can also set Clip’nSave to print whenever you press Clip’nSave’s Active Window
or Desktop hotkeys. Select “Capture Options” from the Options menu, and enable the
“Print Automatically” option. Depending on which hotkey you press, Clip’nSave will
send either the active window or the desktop to the clipboard, Clip’nSave’s window, and
to your printer.
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In Case of Trouble...

Printing problems are sometimes difficult to diagnose. If your system configuration is
incorrect, it’s possible that programs may “crash” and disappear with no explanation.

The following suggestions are based on our own experience with Windows printing. This
list is by no means exhaustive.

1. Check your printer configuration.

Run the Printers function from the Windows Control Panel, and double-check the
configuration and setup for your default printer.

Common mistakes include associating the wrong device to a printer (e.g. LPT2 instead
of LPT1), or redirecting output to a disk file.

When you’re satisfied with the software configuration, make sure the printer is properly
connected, on-line, and that all switches and settings on the printer itself are correct.

2. Check the timeouts.

When printing to certain PostScript printers, the unit may go idle without printing the
image. The problem occurs more frequently with large bitmaps than small ones.

This problem is sometimes caused by timeouts. Select “Print Setup...” from Clip’nSave’s
File menu, and press the “Setup” button. This will display the printer driver’s dialog box,
where you can usually increase the timeout values. We found that 600 works well and it
can be set as high as 999 if problems persist.

3. Try another application.

If you have another Windows program, try printing something with the other program. If
the other program also fails, the combination of error messages from both Clip’nSave
and the other program may help diagnose the cause.

4. Reboot and cross your fingers.

When all else fails, shut down all running programs, reboot your computer and restart
Windows.

You will be surprised how often this works.
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Printer Setup

Select “Print Setup...” from the File menu. This will display a dialog box listing the
available printers:

Figure 4-20. “Printer Setup” dialog box.

The highlighted printer is the one that will be used for the print job. If more than one
printer is active, you can select a different printer by clicking on its name with the
mouse.

You can change the highlighted printer’s setup, or add a new printer by pressing the
“Setup” button. This will display the dialog box for the currently selected printer driver.
The dialog box lets you change the printer’s setup, or add a new printer to your setup.

Changes you make to the printer setup are the same as those you make from the “Print-
ers” icon in the Windows Control Panel. They remain in force from session to session
until you change them again.

For more information on printer drivers, refer to your Windows User’s Guide.
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Chapter
Tips’nTricks 5

What You’ll Learn in this Chapter

Several months of testing resulted in very good feedback, suggestions, and advice. What
follows is a collection of several “tips and tricks”, many of which were suggested by
users.

Use Shortcuts

Remember that there are three ways to invoke all screen capture functions:

• from the Clip’nSave Capture menu;

• from the Clip’nSave Control menu (see A Note on the Control Menu at the begin-
ning of Chapter 4); and

• from the keyboard.

The Capture item on the Clip’nSave Control menu is included so that you can invoke a
screen capture even while Clip’nSave is minimized.

The hotkeys let you capture anytime, even while you’re in the midst of an operation in
another program. You can be halfway down another program menu, or in a program
dialog box, or resizing a window, and Clip’nSave will still get the shot. This makes it
great for illustrating program instruction manuals.

If you want the mouse pointer to appear in your hotkey captures, remember to enable it
in Capture Options on the Options menu.
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Hardcopy with One Keystroke

You can set Clip’nSave to print whenever you press Clip’nSave’s Active Window or
Desktop hotkeys. Select Capture Options from the Options menu, and enable Print
Automatically. Depending on which hotkey you press, Clip’nSave will send the active
window or the desktop to the Clip’nSave window, to the clipboard, and to your printer.

To Abort any Screen Capture

To abort a screen capture, simply click the right mouse button once. When Hide While
Capturing is disabled in Capture Options, you can also cancel by pressing the Esc key.

File Exchange with the Macintosh

If you edit your Clip’nSave bitmaps on an Apple Macintosh, we recommend that you
save the files as TIFF with PackBits compression. If that doesn’t work, try Encapsulated
PostScript with and without compression. Most Macintosh programs with graphics
capabilities will successfully import either TIFF or Encapsulated PostScript.

High-Resolution Image Printing

We discovered that the best file format for high-resolution reproduction of screen images is
Encapsulated PostScript. With the screen preview, you can position, scale, and crop the
image from within your word processor, graphics program, or desktop publisher.

We ran some tests by proofing PageMaker documents containing Clip’nSave PCX,
TIFF, and EPS files on a QMS PS410 at  300 dpi. We then printed the very same files on
a high-resolution imagesetter at 2540 dpi. The EPS files came out the winner, especially
when it came to handling continuous tone images like those produced with the grayscale
option turned on.

Image Editing Under Windows 3.0 or DOS

Try the Windows 3.0 Paintbrush accessory. Windows Paint now supports both .BMP
and .PCX  files — including black-and-white, grayscale, and 16 or 256 colors. Also, if
you have loaded or captured a bitmap, you can paste it directly into Paintbrush using its
Edit menu. If Paste is “grayed out”, you probably have a DIB and not a bitmap on the
clipboard. Currently, Windows Paintbrush only works with bitmaps.

An alternative is ZSoft Publisher’s Paintbrush for Windows which accepts all Clip’nSave
PCX and TIFF formats and can paste either clipboard bitmap format. A DOS version of
Paintbrush is also available.
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Cutting & Pasting with Other Applications

Since anything that appears in Clip’nSave’s window is already on the Windows clip-
board, there is no need for Cut, Copy or Paste commands. You don’t have to cut or copy
them there. Other programs can use their Edit menu’s “Cut” and “Paste” commands to:

• Paste bitmaps currently in the Clip’nSave window into applications that will accept
a bitmap or a “device-independent” bitmap (DIB).

• Copy or cut bitmaps from a graphics application into Clip’nSave.

You can paste bitmaps directly from Clip’nSave to programs like Corel Draw, ZSoft
Publisher’s PaintBrush, Aldus PageMaker, Microsoft Word for Windows and others. If
you have trouble pasting bitmaps, use the View menu to check which format is on the
clipboard. If it’s a DIB bitmap, try a bitmap and if it’s a bitmap, try a DIB bitmap. To
change format, re-load or re-capture the bitmap after setting the “Load As” or “Capture
As” options properly. Then try to “Paste” again.

If you find the program won’t import from the clipboard, use Clip’nSave to save it to a
file format the program can import, and then import it from disk.

Remember that when you import EPS files into Pagemaker, the screen rendition is in
black & white and at much lower resolution than the final printed version. Before you
decide it’s garbage, print it. It looks much better on a high resolution printer.

Poor Man’s DDE

Windows Dynamic Data Exchange, or DDE for short, is a feature whereby updates to an
object in one program are automatically replicated in other DDE-linked programs.

We like to think of Clip’nSave as sort of a poor man’s DDE where the Clip’nSave client
window immediately updates itself when you copy a bitmap to the clipboard. With a
click of the mouse, you can switch programs and paste the bitmap into another program.

Resizing Graphics

Within Clip’nSave you can resize graphics by capturing the graphic, enabling Stretch to
Fit in the View menu, and then making the Clip’nSave window the size you want. Turn
off Hide While Capturing in Capture Options, select Hide Window Controls from the
View menu, and perform an Active Window or Client Window capture.

Within the PageMaker and Word for Windows programs, you can maintain the aspect
ratio while resizing an image. Hold down the Shift key while selecting a corner of the
bitmap.
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Testing Your Clipboard Code

If you’re a software developer implementing clipboard cut and paste functions, use
Clip’nSave to visually confirm that your code is working.

Don’t forget to check the Clip’nSave Bitmap Description Window to verify that your
dimensions and color formats are accurate.

Fine-Tuning your new Window Controls

If you’re finding it difficult to properly position and size small objects on the screen,
then use a Clip’nSave Rectangle Capture to cut out the area of interest and “zoom” in on
it using the Stretch To Fit option.

Stretch To Fit was used extensively during Clip’nSave development to confirm that the
many new window controls (i.e. Status Window, Bitmap Description Window, and
Home-up Button) were drawn and scaled correctly.

Using Clip’nSave to Prepare Presentations

If you need to discuss your new application’s user interface with others, use the Capture
and Print functions to quickly obtain printed copies of your window designs.

To “spice up” your presentation, save the bitmaps as TIFF or PCX files and import them
into a program like Harvard Graphics or Microsoft PowerPoint.

Converting Graphics to Black & White

Load or capture the graphic, and save it with “Color Mapping” set to B&W . Then reload
the black and white image from disk into Clip’nSave.

Remember that when you save as black & white, all other color information is lost. If
you don’t want to lose the color info, save twice –  first as a color file, and then as a
black and white file under a different name.

Using Halftoning to Print Color and Grayscale Bitmaps

Halftoning is a printing process whereby continuous tones are imaged with tiny dots of
varying size, shape, and number — the dot patterns resemble the original tones and
shades. Halftoning can be done by software or hardware.

PostScript printers implement halftoning, and Windows supports it – for printers like the
HP LaserJet II – through printer drivers.
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If you have a program like Ventura Publisher, PageMaker, Microsoft Word or WordPerfect,
save the bitmap to disk and print it with the other program. All of these programs implement
halftoning in software and the results are usually well worth the extra trouble.

To Save Bitmaps as PostScript Files

Two ways to save a bitmap as a PostScript disk file:

• Use Save As... to save as Encapsulated PostScript (EPS) if you prefer to have a
TIFF screen preview component added to the file; or

• Set up a PostScript printer as the system default (even if you don’t really have the
printer) and then use Printer Setup... to instruct the driver to print to a disk file.

Custom Wallpaper and Full-Screen Bitmaps

Custom desktop backgrounds, or “wallpaper” as they’re sometimes called, are very
popular.

Typically, the backgrounds consist of full-screen or tiled Windows bitmap files (i.e. .BMP
file extension). Tiled bitmaps are easy to create — simply save any bitmap to disk in
Windows Bitmap format.

To create full-screen bitmap images from smaller bitmaps:

1 Capture the desired image, or copy it to the clipboard from another program.

2 Turn off Hide While Capturing from the Capture Options dialog, and turn on
Stretch To Fit from the View menu.

3 Maximize the Clip’nSave window.

4 Select Hide Window Controls from the View menu (CTRL-H is the shortcut).

5 Invoke a Client Window capture by typing CTRL-C. Then, click the mouse anywhere
on the resized bitmap.

6 Double-click the mouse to make the window controls reappear, and select Actual
Size from the View menu to turn off bitmap stretching.

7 Save the bitmap in Windows Bitmap format.

Flexible Logos

Design your company’s logo with a Windows graphics editor or desktop publishing
program. Display it in “Actual Size”, then capture and save it with Clip’nSave.



5-6   Tips’nTricks

Do-It-Yourself Icons, Pointers, and Bitmaps

You can use the Rectangle and Client Window capture functions to create icons,
pointers, and custom bitmaps from anything that you see on the screen.

To copy another program’s icon, use a Client Window capture and simply point and
click on the icon. Due to a quirk of Windows, the icon is captured as a 36x36 bitmap. It
must be cropped to 32x32 before it can be pasted into the Icon Editor. To create custom
icons, pointers, or bitmaps from other parts of the screen, use a Rectangle Capture and
size the capture area to 32x32 via the Show Rectangle Size option.

After you capture the bitmap, start the Icon Editor and select New... from the File menu.
Then simply paste the bitmap directly from the clipboard.

Capturing the Clip’nSave Window

We already mentioned this in Chapter 4 but it’s worth repeating.

When you turn off Hide While Capturing from the Options menu, you can capture
bitmaps already displayed in the Clip’nSave window. Review the section entitled The
View Menu in Chapter 4 to see how you can use this feature to crop and scale bitmaps.

Adding a Border to Your Graphics

Another useful option is the ability to automatically outline captured images. Before
using the capture function, select Capture Options from the Options menu and turn on
Draw Box Around Bitmap.

Capturing Menus that Extend Beyond the Frame Window

A Window capture will sometimes cut off part of a command menu that is partially
displayed outside of the frame window’s border.

To capture the frame window and a command menu that extends beyond the frame
window’s border:

1 Capture the entire Desktop with F12.

2 Turn off Hide While Capturing.

3 Use a Rectangle Capture to crop out everything except the frame window and the
command menu.
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Converting Text to Graphics

With PageMaker or a similar application, you can use Clip’nSave to convert a text block to
graphic format. You can then expand or condense this text block as you would any graphic.

To use this feature, capture the text block from the application’s client window with a
Rectangle Capture. Then paste the image back into the application via its Edit menu.

If the other program has a page preview mode, you can also select and place an entire
page using the same technique. Consider turning on the Draw Box Around Bitmap
option to have a rule drawn around the graphic.

Reporting User Interface Problems

Some of our customers use Clip’nSave to report user interface problems with new
applications. To report a problem, the tester captures the screen image and sends the file
back to the programmer.

Multiple Clip’nSave Windows

You cannot run more than one copy of Clip’nSave. The Clip’nSave window displays the
system clipboard and there’s only one system clipboard.

Resetting the System Colors

If Clip’nSave ends prematurely, or if you abort the program with the Task List, your
system colors may not reset properly.

If this ever happens, restart Windows to restore the colors you originally selected.

Unblinking the Cursor

If you have trouble including the blinking Windows text cursor in your screen snapshots,
use the Control Panel to set Cursor Blink as slow as possible.

Capture DOS Screens

You may find that the hotkeys can’t capture a windowed DOS screen. Instead, minimize
Clip’nSave and from the Control menu invoke a Client capture. Simply point the hand at
the DOS screen you want and click it.
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Reversing the Colors of DOS Screens

Windowed text-mode programs (DOS programs on 386 and 486 machines) remain
unaffected by any change to the default system colors.

The problem is particularly obvious when working with black & white screen capture
because the DOS text — gray on a black background — is represented in monochrome
bitmaps as black on black.

A way around this problem is to use the prompt  command to change the window’s
default background and foreground colors.

For example, the command prompt $e[7m$p$g  will set the default colors of a DOS
window to black text on a white background.

Dealing with Hotkey Conflicts

Some programs may conflict with the Clip’nSave system-wide hotkeys.

If your hear a “beep” when you press F12 to capture the desktop — or if the system
hangs — then we recommend that you change the system-wide hotkeys.

Two alternate sets of system-wide hotkeys are as follows:

Active Window: CTRL-SHIFT-F1
Desktop: CTRL-SHIFT-F2

Active Window: SCROLL LOCK

Desktop: SHIFT-SCROLL LOCK

Printing Bitmaps - How this Manual was Made

While our previous manuals were prepared on a Linotronic 300, this manual was “typeset”
on a QMS PostScript laser printer to demonstrate the image quality possible with widely
available equipment.

All the illustrations in this manual were captured using Clip’nSave. The images were
saved in grayscale, LZW-compressed TIFF files and imported into Aldus PageMaker as
“independent graphics”. The PageMaker “image control” command was used to set each
image’s halftone frequency to 90 lines per inch. Since only a few shades of gray are used
in each illustration, we were able to use this halftone frequency, which is normally used
only for high resolution typesetters.

The halftone frequency can be controlled in many desktop publishing programs. Also,
the PostScript printer driver in Windows 3.1 contains an “advanced” dialog box in which
the halftone frequency and angle may be adjusted.
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Appendix
File

Formats A
File Formats

This appendix describes the clipboard bitmap formats and disk file formats supported by
Clip’nSave.

Bitmaps and the Clipboard

To understand how best to use Clip’nSave, it’s a good idea to know what bitmaps are,
how the Windows clipboard works, and how Clip’nSave makes use of both bitmaps and
the clipboard.

What is a bitmap

Simply put, a bitmap is a collection of bits representing colored dots that, when correctly
interpreted, make a picture. Bitmaps also contain information about the picture: such as its
dimensions, the number of bits used for each pixel or dot, and the palette or selection of
colors used.

Windows defines two standard formats for bitmapped images: bitmap and “device-
independent” bitmap (DIB). Throughout this manual, these are called bitmaps and
DIBs respectively.

The next sections describe each format.
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Bitmap format

A bitmap is a piece of Windows memory that represents the colored dots that make up a
picture. It also includes information about the picture, such as its size, the number of bits
used for each pixel or dot, and the palette of colors required to  paint the picture. The
format of a bitmap varies according to the device that it was created for. For instance, a
bitmap created for the VGA display is different from a bitmap created for a Hewlett
Packard LaserJet III.

Some bitmaps use only 2 colors, black and white; others may use as many as 16 or 256
different colors in their respective palettes; still others may contain a selection drawn
from over 16 million different colors.

Bitmaps are used throughout Windows. The mouse pointer, icons, characters, and
windows are all bitmaps. In fact, the entire screen is one big bitmap.

DIB or “device-independent” bitmap format

“Device-independent” bitmaps (DIB) are also bitmaps. The only difference is the device
that a bitmap is created for decides its format while the format of a DIB never changes.
As Windows continues to support more devices, supporting all the different bitmap
formats becomes awkward. With DIBs, programs can use one universal format that
describes the appearance of an image in a device independent manner. DIBs can be
created by or output to any device. Many older programs don’t yet support DIBs.

When you load a bitmap onto the clipboard

The Windows system clipboard (displayed in Clip’nSave’s window) is an area of shared
computer memory that can be accessed by many Windows programs. You can place data
on the clipboard by:

• Using any program’s Edit menu to perform a Cut or Copy command;

• Performing a capture with Clip’nSave;

• Loading a file into Clip’nSave.

The Windows clipboard accepts data in many formats. To understand one another,
programs communicating via the clipboard must use the same format.

Since Clip’nSave works only with bitmapped data, anything you place on the clip-
board – either by capturing an area of the screen, or by loading a file from disk –
will be in one or both Windows bitmap formats. The format created by captures is
set by clicking the appropriate buttons in the “Capture as” dialog on the Options
menu. The “Load as” button in the File.Open dialog box determines the format when
loading bitmaps from files.
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The Clip’nSave View menu tells you which format is currently displayed. When a
bitmap is on the clipboard in both formats, you use the View menu to select which one
should be displayed.

Pasting from the clipboard

The data on the clipboard is pasted straight into a program when you use its “Paste”
command.

Some programs can accept both Bitmaps and DIBs; others accept only one or the other.
If you have trouble pasting a Bitmap, try switching to a DIB and vice versa.

File Formats

File formats define how bitmaps are stored on disk.

• When you load a file into Clip’nSave, you load it onto the Windows clipboard
as well. The file is translated from its original disk format into either a bitmap or DIB,
depending on the setting of the “Load as...” buttons in the File menu’s Open dialog box.

• When you save a file, you save the contents of the clipboard. As it is saved, the
image is converted from bitmap or DIB format, to the disk file format specified in the
“Save As...” dialog.

Disk file formats supported by Clip’nSave, and their respective attributes, are presented
in the tables below. Each format is described in detail later in this chapter.

Clip’nSave can import and export the following file formats:

Format Import Export
Windows Bitmap (.BMP) Yes Yes
Device Independent Bitmap (.DIB) Yes No1

Run Length Encoded (.RLE) Yes No1

OS/2 Bitmap (.BMP) Yes2 Yes
Encapsulated Postscript (.EPS) No Yes
Graphics Interchange Format (.GIF) Yes Yes
PC PaintBrush (.PCX) Yes Yes
Tagged Image File Format (.TIF) Yes Yes

Table A-1. File formats supported by Clip’nSave.

1 Device Independant Bitmaps and Run Length Encoded files are different flavors of the
standard Windows Bitmap format, and as such, are not specifically supported for export.

2 To import OS/2 bitmaps, select “Windows Bitmap (.BMP)” as the file format.
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The following outlines the features of the various formats:

Format B&W Grays Color Compress
Windows Bitmap (.BMP) Yes Yes Yes Optional
Device Independent Bitmap (.DIB) same as .BMP
Run Length Encoded (.RLE) same as .BMP
OS/2 Bitmap (.BMP) Yes Yes Yes No
Encapsulated PostScript (EPS) Yes Yes Yes Optional
Graphics Interchange Format (.GIF) Yes Yes Yes3 Always
PC Paintbrush (PCX) Yes Yes Yes Always
Tagged Image File Format (.TIF) Yes Yes Yes Optional4

Table A-2. Colors and compression available for each file format.

Format Decompressed Compressed
Windows Bitmap 153,718 35,604
Encapsulated PostScript 347,634 74,197
OS/2 Bitmap 153,682 cannot be compressed

PC Paintbrush always compressed 65,243
TIFF — PackBits Compression 154,002 29,007
TIFF — LZW Compression 154,002 17,637
GIF always compressed 14,801

Table A-3. Disk space requirements for a typical full-screen bitmap.

Windows Bitmap (.BMP)

The Windows Bitmap (.BMP) is the device independent format introduced by Microsoft
with Windows 3.0. Earlier versions of Windows also had .BMP files but these were
device dependent and are no longer supported. Most Windows programs that use
bitmaps support .BMP files. Internally, the files closely resemble Windows’ “device-
independent” bitmap (DIB) format. This makes it simple for programs to read and write
.BMP files.

The Windows Paintbrush program can read and write .BMP files. Windows wallpaper
files are also .BMP files.

Clip’nSave can create black & white, grayscale, and up to 24-bit color. They can also be
compressed.

3 Except 24-bit color
4 With TIFF files you can select from three possible compression schemes:  none, PackBits, or

Lempel-Ziv-Welch (LZW).
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Device Independent Bitmap (.DIB)

.DIB files are the same as .BMP files. The extension may be used to avoid confusion
since .BMP files prior to Windows 3.0 were device dependent.

Run Length Encoded (.RLE)

.RLE files are .BMP files that are compressed using Run Length Encoding. The extension
simply makes it easier to identify the file’s format.

OS/2 Bitmaps (.BMP)

OS/2 bitmaps normally use the same extension as Windows bitmaps – .BMP. OS/2
bitmaps are device independent and resemble Windows .BMP files although there are
several differences. One important difference is that OS/2 bitmaps cannot be compressed.

Encapsulated PostScript (.EPS)

PostScript is a page description language developed by Adobe. Due to its great flexibility,
PostScript has been widely adopted by printer manufacturers and software developers.

One of PostScript’s best features is its resolution and device independence. The fact that
you can send the same file to a 300dpi laser printer and to a 2540dpi typesetter has made
PostScript the lingua franca of desktop publishers.

Encapsulated PostScript is a type of PostScript file that’s self-documenting so that the
same file can be read without modification by several programs.

Clip’nSave can save any bitmap to an EPS file. It cannot load and display EPS files
since displaying a PostScript file requires a PostScript interpreter.

Since very few programs can interpret PostScript, it can be difficult to preview the
contents of a PostScript file. To make viewing and editing easier, Adobe extended the
Encapsulated PostScript specification to include a low-resolution TIFF version of the
image inside the Postscript file.

Clip’nSave creates EPS files that contain EPS code and a low resolution, black-and-
white TIFF version of the image. When viewing and editing the bitmap on-screen, you
see the TIFF component. When printing, it’s the higher quality PostScript version that is
output.
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Raw PostScript

If you want to create a Clip’nSave file in raw PostScript instead of Encapsulated PostScript,
setup a PostScript Printer driver using the Printer Setup command on the Clip’nSave File
menu. Set the printer driver to print to a file instead of a printer port, and then use the Print
command on the same menu. The resulting file will be a raw PostScript file. If you want color
PostScript, select the QMS ColorScript 100 driver.

To save disk space when printing to disk, you should check “compress bitmaps” in the
printer driver’s setup dialog box if this option is available.

Graphics Interchange Format (.GIF)

Graphics Interchange Format is a format devised by Compuserve for use as a graphics
interchange standard on their computer information service. It has since become one of
the most widely used formats for storing pictures on electronic bulletin boards.

GIF files are always saved in an LZW compressed format, and can display black &
white, grayscale, and 16- and 256-color images, but not 24-bit color.

GIF files can contain more than one image. If you load a multi-image file into Clip’nSave,
only the first image in the file will be loaded. Clip’nSave creates only single image GIF
files.

When you select .GIF format, an “Interlace” option appears on the dialog box. Interlaced
files are organized internally so that they may be previewed very quickly. Bulletin board
users benefit greatly from being able to preview a file quickly before downloading the rest.
Clip’nSave reads and writes interlaced files although it doesn’t use the previews.

Compuserve has published two versions of the GIF specification to date: 87a and 89a.
Clip’nSave reads files of either format,  but is unable to render text that may be embed-
ded in GIF 89a files. Files are always written according to the 87a specification.

Tag Image File Format (TIFF)

Another very popular image format is the Tag Image File Format, or TIFF for short,
developed by Microsoft and Aldus. The advantages of TIFF are its flexibility and wide-
spread acceptance. Nearly all Windows, OS/2, DOS, Unix, and Macintosh programs with
graphics import capabilities can read and write TIFF files. Additional features contributing
to TIFF’s efficiency include the ability to store several images in a single file and the
variety of compression schemes.

The disadvantage of TIFF is its complexity. Because TIFF is such a flexible format,
importing an arbitrary TIFF image is very tricky. Programs must deal with Mac-to-PC
conversion, palette vs. 24-bit color vs. grayscale images, at least three different compres-
sion schemes, overlapping images, images broken into strips, and so on. Consequently,
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there are many programs that don’t correctly interpret other programs’ TIFF files. To
avoid this problem, Clip’nSave can save clipboard bitmaps to disk in several TIFF
formats using various compression schemes. We suggest that you experiment to find the
one that best suits your needs.

Clip’nSave reads and writes black & white, grayscale, and 4-, 8-, or 24-bit color TIFF
files. Compression options include: none, PackBits, and Lempel-Ziv-Welch (LZW).

Clip’nSave also reads CCITT compressed TIFF files but it can't write them.

ZSoft PC Paintbrush Format (.PCX)

ZSoft is the manufacturer of Publisher’s Paintbrush, one of the most widely used paint
programs for DOS computers. As a result, the ZSoft PCX file format is a de facto
standard for storing paint-type images. The addition of grayscale, 256-color and 24-bit
color support, combined with a simple compression scheme, make the PCX format
flexible and efficient.

PCX, like TIFF, is one of the most widely supported file formats in DOS computers. In
terms of complexity, PCX lies somewhere between TIFF and Windows bitmaps.

An interesting aside: the Windows 3.0 Paint program supports .PCX files (although not
in 24-bit color). It also supports Windows and OS/2 bitmaps.

Clip’nSave reads and writes black & white, grayscale, and up to 24-bit color PCX files.
When saved to disk they are always compressed using run length encoding.
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